Saturday, August 23, 2008

One or more features must be turned on before this feature can be activated.

Scenario:
You are trying to activate Office SharePoint Services Publishing feature and get following error.

Error SP2010:
The SharePoint Server Publishing Infrastructure feature must be activated at the site collection level before the Publishing feature can be activated.


Error MOSS 2007:
The Office SharePoint Server Publishing Infrastructure feature must be activated at the site collection level before the Publishing feature can be activated.


Reason:
The publishing feature (Site Feature) is dependend on the Publishing
infrastructure feature (Site Collection Feature).

Resolution:
For activating the feature, go to

1. Navigate to your Top level site and click on Site Actions > Site Settings 
2. Under Site Collection Administration, click Site Collection Features
3. Click on Activate for Office SharePoint Server Publishing Infrastructure
4. Once that’s activated, Navigate back to site settings page of the site you was getting error.
5. Under site administration, click on Site Features
6. Now Activate Office SharePoint Server Publishing.

Done!!!

11 comments:

Anonymous,  March 23, 2009 at 3:38 AM  

i've done as u said but when i activate Office SharePoint Server Publishing Infrastructure there s a message
"One or more features must be turned on before this feature can be activated" still that is not activated

Sandeep K Nahta March 23, 2009 at 9:49 AM  

Can you check the error log..which feature it is talking about...

Anonymous,  June 24, 2009 at 2:46 AM  

thanks..

bhavikm20 November 12, 2009 at 4:54 AM  

Thanks man for this article

Anonymous,  February 26, 2010 at 12:41 PM  

You are the Man!!!

Thanks!

Anonymous,  February 26, 2010 at 9:38 PM  

Thank you for sharing your knowledge. God bless you.
Thanks again!

Anonymous,  February 26, 2010 at 9:43 PM  

Thank you for sharing your knowledge. God Bless!

Abul,  March 14, 2010 at 9:48 AM  

Thanks a lot.. It worked for me.. Many people would miss the "site collection settings".

soccerdiva990 May 23, 2010 at 2:55 PM  

I'm at the top level of my site collection and when I attempt to turn on the SharePoint Server Publishing Infrastructure, I'm getting this error.

Anonymous,  June 6, 2012 at 4:33 AM  

Great, Thank you!